ajaxPartial works only on fresh install but not on updated system

Hi All,

I like all the features of the new version of OctoberCMS 3.2. The most interesting for me the ajaxPartial which makes a lot of things more easier.

I have updated one of my applicaton from v3.1 to use OctoberCMS v.3.2.1 and tried out the ajaxPartial, but unfortunately it does not work.

My first thought was that partial is wrong or something is missing from my layout/page so I just created a fresh OctoberCMS environment with the latest version (3.2.1) and I tried out the same partial on the demo theme of OCMS. It worked.
Then I copied my own theme files to the fresh installation and checked the ajaxPartial again…and it worked!

The same code did not work in the updated framework (from 3.1.29 >> to 3.2.1) but it works fine on a newly installed OctoberCMS system.

Do you have any idea what could be the problem?
Does ajaxPartial should work only on a newly installed system with at least 3.2.1 version?

Thank in advance for your help,

Hi @vimre

It is worth checking that the framework files are not being cached on the upgraded site. Try clearing the browser cache to get the latest AJAX framework files loaded.

Hopefully it helps.

Bingo! :slight_smile:
I do not know why it was not the first thing I tried, Thanks for help!

Ps.: Thanks for this update. It has a lot of amazing and long awaited features. Plus the new ‘Features’ section of the Documentation is very useful to learn the logic of different functons and the way how to connect them to each other to achive the goal the most easiest way (I hope you will extend the list of these kind of documentations and tutorials). I can’t wait to update and refactore my previous applications :slight_smile:

1 Like