Backend markup classes don't work in RichEditor

Hi there,

I’ve added a couple new classes for images to the editor settings and deleted the pre-installed classes, since I don’t need them. But the css changes are not applied. I do see the new classes in the richeditor pop-up, but the css doesn’t update.

I’ve tried clearing the cache multiple times, re-compiled the assets and manually deleted the cache to see if it would work. Nothing really helped…

I’ve added the custom css to the ‘Markup Styles’ tab and to my theme.

Does anybody know how to resolve this?


  • Kevin

Hi and welcome @kevin-invato,

We have tested this today and it appears to be working in October CMS v3.2.

  1. Navigate to Settings → Editor Settings
  2. Select Markup Classes tab, under Image add
  3. Label: Foobar, Class name: oc-foobar
  4. Click Save

The style now appears when selecting an image