October running in laradock

I use Laradock on mac as my local environment

Currently i use an older instance of Laradock for my local environment and it works fine.

I attempted to update to the latest version of Laradock and the site stopped working.

The only output or clue as to whats going on that i get is in the apache error log which shows

“[Thu Jun 16 16:24:52.728631 2022] [proxy_fcgi:error] [pid 22:tid 140061655668480] [client] AH01071: Got error 'PHP message: PHP Warning: Uncaught Illuminate\Contracts\Filesystem\FileNotFoundException: File does not exist at path /var/www/storage/framework/cache/85/4a/854a54028c654716bc56a9a9c41d98b9641d8f9b”

I have tried the following

  1. Making sure to run “october cache:clear” before switching to the new Laradock version.

  2. making a copy of the ‘/storage/framework/cache’ folder before switching Laradock version and copy/pasting it back in place before attempting to load a page using the latest Laradock version.

  3. placing a die() statement in the index.php file ( to make sure the http request is actually being served to the browser properly - it is.

  4. Keeping my Laradock .env file identical except for new values required by the latest version of Laradock.

  5. I have not yet tried the new Laradock version with a Laravel project but I intend to do so.

This list of things attempts to eliminate the following as possible causes of the issue.

  • Missing cache files
  • Laravel itself ( rather than October )
  • My .env file
  • apache

I have switched between Laradock versions several times and the old version always works the new one has the error described.

My process for switching Laradock versions is to run docker-compose down, restart docker engine, run docker-container-prune and finally run docker-compose -d --build < list containers > from the folder containing the version of Laradock I wish to use.

Any ideas?

When it complains that the file does not exist, it can either mean:

  • it doesn’t have permissions; or
  • there is a sticky file reference in there (fixed by clearing cache)

I suspect it could be a permissions issue.

I tried chmod -R laradock:www-data ( the same name and group that all the other files have )
and it didnt fix it

This has now been fixed

if xdebug v3.1.2 is installed and running i get the problem
with xdebug v2.9.8 there is no problem
( laradock had upgraded xdebug between my old version and the current version )

Does anyone know why the Xdebug version may have caused this issue, how it can be investigated further and how it can be fixed?

1 Like

October CMS interacts with XDebug in October\Rain\Foundation\Bootstrap\LoadConfiguration:

// Fix for XDebug aborting threads > 100 nested
ini_set('xdebug.max_nesting_level', 1000);

Since it uses ini_set so is relatively benign. There are no other interactions with XDebug in the system, so it suggests it might be something unrelated to the platform.