Strange behavior after update to octoberCMS to version 3 from version 2


I’ve just updated an octobercms and deploy it to the production site. But when I visit the site I’ve got 404 for every page. When I turn on the debug mode in .env file its working like a charm, but when I turn it off its got 404. I think the problem is in database, because it occur when I migrate the database.

Very strange is that on my local enviroment its working without 404. Also with production database and debug mode set to false.

Any idea?

I think that if you turn debug off, you need to set CMS_SAFE_MODE to off also in OC3.

Still not working, I set the CMS_SAFE_MODE to false, but when I turn off the debug mode - still getting 404.

Could be something with open_basedir restrictions? Becouse somewhere in backend I’ve got this error:
“file_exists(): open_basedir restriction in effect. File(/02.jpg) is not within the allowed path(s):” …

I have fixed it - upload of storage directory resolve the problem. I didnt upload it first time, because it has production uploads in it.