Translatable:false error in Tailor blueprint


I have encountered an issue with the “volunteers_finish_date” field in a blueprint file. Despite filling up the field after migration and setting “translatable: false,” I am facing an exception stating, “Volunteers finish date is required.” It seems the filled information is not being recognized.

Here is the relevant part of the blueprint file for your reference:

yamlCopy code

    label: Volunteer's finish date
    type: datepicker
    mode: date
    validation: required|date|after:start_at
    span: right
    translatable: false

I would appreciate any insights or assistance in resolving this matter. Has anyone encountered a similar error before?

Thank you for your time and assistance.

Best regards, Zs

Hey @ngyzsolt

This looks like a bug, indeed. When the field is added and is required, the field starts out empty, so propagation of those records fails.

We’ve skipped validation for propagation to overcome this error: Skip validation for propagation · octobercms/library@845e5d1 · GitHub

Hi @daft,

I’ve discovered another bug related to the translatable: false property in Blueprints of type global. When the translatable: false property is added to the title or icon fields in my blueprint and I press Save in one site (language), the values of the icon or title (in my blueprint) are set to the default value in other sites (languages). If no default value is added, the icon or title value will be null.

Here is my blueprint:

uuid: ea1b70e3-049c-4ad0-82a2-4a7c9ffe3e94
handle: Camps\About
type: global
name: About camps
drafts: false
multisite: sync

    icon: icon-tree
    parent: Camps\Camp
    order: 14


         label: Title
         type: text
         validation: required|string|min:5|max:50
         commentAbove: 'Min 5 and max 50 characters'
         span: left
         default: Despre taberele Yuppi
         tab: Camps - General
         translatable: false

        label: Icon
        type: radio
        span: left
        cssClass: inline-options
            house: House
            cloudy: Cloudy
            none: None
        required: 1
        default: none
        tab: Camps - General
        translatable: false

I would really appreciate it if you could take a look at this.

Kind regards,

Hey @ngyzsolt

The multisite: sync option was not supported in global blueprints. However, we have fixed support for it in v3.6.19.

1 Like