Installation does not work

require php ^7.2 → your php version (8.1.6) does not satisfy that requirement

Wtf is this guys? Even if I read your installation requirements it says that I need PHP 7.4 or higher which isn’t working anyway with that. I tried all version combinations available of cms and php and it does not work!

How to install it or should I just go to something that just works and never deal with PHP again?

Of course you can do that, but then you will miss a fantastic CMS / CMF.

And when you change your composer.json file with:

"require": {
    "php": "^7.4|^8.0",
    .....
},
1 Like

I have an OctoberCMS v2.2.27 with PHP 7.4.9 and the application is running well.

If you can, downgrade your PHP version.

From what I can read from Slack :

TimFoerster [5 months ago] (Slack)

I work and develop ocms with php 8.0, thats not an issue. Depending on plugins obv.

TimFoerster [5 months ago] (Slack)

try php 7.4, this should work

Hopefully it helps…

This does not come from October itself. It comes from it’s dependency - Laravel. It looks like used version of Laravel is not compatible with what’s October wants to use. This looks strange.

I tried all recent versions available. For the suggested 7.4 version - composer doesn’t know that the package for version 2.0 exists. I’ve got different error.

This full log with version 8.0.19

Problem 1
- laravel/framework[v6.20.0, …, 6.x-dev] require league/flysystem ^1.1 → satisfiable by league/flysystem[1.1.0, …, 1.x-dev].
- laravel/framework[v6.0.0, …, v6.19.1] require php ^7.2 → your php version (8.0.19) does not satisfy that requirement.
- league/flysystem[1.1.0, …, 1.x-dev] require ext-fileinfo * → it is missing from your system. Install or enable PHP’s fileinfo extension.
- Root composer.json requires laravel/framework ^6.0 → satisfiable by laravel/framework[v6.0.0, …, 6.x-dev].

With 8.2.x it’s the same. With version less than 8.0 it even does not want to install at all complaining that it does not know what is October 2.0 at all.

I had old version running well. And I didn’t touch the project for a while. I migrated to new machine and installed composer, tried to run the project and it failed to do so. Ok, no problem - lets use the most recent version - and clean install does not work either.

I tried all version combinations available of cms and php and it does not work!

Why try all the combinations? The docs state what versions are compatible:

Please note that October CMS v2 is not compatible with PHP 8.1, the version 3 beta is available to meet this requirement. It is recommended to downgrade to PHP 8.0 and use version 2 for the best stability and support.

October 1: 7.2-7.4
October 2: 7.4-8.0
October 3: 8.0+

Of course, the real limiting factor will be what plugins/packages you have installed. So without you posting your full composer.json, it is hard to help you.

How to install it or should I just go to something that just works and never deal with PHP again?

Also, you will receive a lot more help if you keep such things to yourself. If something does work for most people but not for you, chances are that you are doing something wrong.

2 Likes

Because none of the listed in docs work for me.

What kind of packages are you talking about? It’s a completely clean install on a completely clean machine with a command from docs:

composer create-project october/october myoctober "^2.0"

Oh, yes. Sure it’s my curly hands! Thank you! Understood: october community is crowd of vulnerable children.

This is not a community of vulnerable children. It is a friendly and grown up community where the founders or community members try to help each other in a civilized way.

Apparently, different rules apply to you. When you are pointed out to communicate in a friendly way you feel attacked.

So Do you have the PHP Fileinfo extension installed? That would fix this issue since flysystem requires it

league/flysystem[1.1.0, …, 1.x-dev] require ext-fileinfo * → it is missing from your system. Install or enable PHP’s fileinfo extension.

1 Like

Yep, I’ve enabled it. It helped to pass laravel step. but turned into more complaining after. The laravel alone installs and works just fine. Anyway, I don’t want to invest more time in that. If it does not work on a clean machine with the provided “manual” it’s useless - obviously something is broken, be it manual or the package itself.

I see different issues with install since 2017, complaining on packages and version compatibility. That’s like several years till now and it doesn’t look some one bothers to fix it.

“It works on my machine”. Nice job. This is a student’s level argument. Farewell october community.

Please communicate with courtesy and respect. First warning (see rules)

You’ve proceeded past basic PHP configuration. The issues discussed here stem from third-party packages and common web server requirements, not from October CMS.

Some suggestions:

3 Likes